aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-09-01 12:15:50 +0200
committerAlex Auvolat <alex@adnab.me>2022-09-01 12:15:50 +0200
commitcd203f5708907c2bf172a3c5b7c5b40e2557b2f4 (patch)
tree8b3eb284106d0f6b5af1ad4ad447c8004ff4c6f5 /Cargo.toml
parent745c78618479c4177647e4d7fed97d5fd2d00d4f (diff)
downloadnetapp-cd203f5708907c2bf172a3c5b7c5b40e2557b2f4.tar.gz
netapp-cd203f5708907c2bf172a3c5b7c5b40e2557b2f4.zip
Add OrderTag to Req and Resp, refactor errors
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 377e09d..5b1cadc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,8 +16,8 @@ name = "netapp"
[features]
default = []
-basalt = ["lru", "rand"]
-telemetry = ["opentelemetry", "opentelemetry-contrib", "rand"]
+basalt = ["lru"]
+telemetry = ["opentelemetry", "opentelemetry-contrib"]
[dependencies]
futures = "0.3.17"
@@ -30,7 +30,7 @@ serde = { version = "1.0", default-features = false, features = ["derive", "rc"]
rmp-serde = "0.14.3"
hex = "0.4.2"
-rand = { version = "0.5.5", optional = true }
+rand = { version = "0.5.5" }
log = "0.4.8"
arc-swap = "1.1"