aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-02-18 19:01:23 +0100
committerAlex Auvolat <alex@adnab.me>2022-02-18 19:01:59 +0100
commitab0f7785ae73e2f5aaf912fc3c0f2cd724967546 (patch)
treeaa5b6d95dd7ccb4560e02352a8c980d077edfed1 /Cargo.toml
parentdc0b5c0305284a1f33417e184c1e4d0ef6e7c032 (diff)
downloadnetapp-ab0f7785ae73e2f5aaf912fc3c0f2cd724967546.tar.gz
netapp-ab0f7785ae73e2f5aaf912fc3c0f2cd724967546.zip
Add telemetry
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3621309..4b6db48 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "netapp"
-version = "0.3.1"
+version = "0.3.2"
authors = ["Alex Auvolat <alex@adnab.me>"]
edition = "2018"
license-file = "LICENSE"
@@ -17,6 +17,7 @@ name = "netapp"
[features]
default = []
basalt = ["lru", "rand"]
+telemetry = ["opentelemetry", "rand"]
[dependencies]
futures = "0.3.17"
@@ -36,10 +37,13 @@ async-trait = "0.1.7"
err-derive = "0.2.3"
bytes = "0.6.0"
lru = { version = "0.6", optional = true }
+cfg-if = "1.0"
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
kuska-handshake = { version = "0.2.0", features = ["default", "async_std"] }
+opentelemetry = { version = "0.17", optional = true }
+
[dev-dependencies]
env_logger = "0.8"
structopt = { version = "0.3", default-features = false }