aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-12-02 16:37:36 +0100
committerAlex Auvolat <alex@adnab.me>2020-12-02 16:37:36 +0100
commit9ed776d16ad40a4d47900814b2b7f1ef1c02fa4e (patch)
treed3658a57df750b2a111887ede6b35cd7bb72bae8 /Cargo.toml
parentf1f2c876a9c95a3acfe4fb43626cb2d50e40df72 (diff)
downloadnetapp-9ed776d16ad40a4d47900814b2b7f1ef1c02fa4e.tar.gz
netapp-9ed776d16ad40a4d47900814b2b7f1ef1c02fa4e.zip
update deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 12 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9c0eadb..4877b79 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,19 +9,24 @@ edition = "2018"
[dependencies]
async-std = { version = "1.5.0", features=["unstable","attributes"] }
tokio = { version = "0.2", features = ["full"] }
-kuska-handshake = { path = "../../handshake", features = ["default", "tokio_compat"] }
+
+serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
+rmp-serde = "0.14.3"
hex = "0.4.2"
+base64 = "0.12.1"
+
+structopt = { version = "0.3", default-features = false }
+rand = "0.5.5"
+
log = "0.4.8"
pretty_env_logger = "0.4"
-sodiumoxide = { git = "https://github.com/Dhole/sodiumoxidez", branch = "extra" }
env_logger = "0.7.1"
-base64 = "0.12.1"
-rmp-serde = "0.14.3"
-serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
arc-swap = "1.0"
-structopt = { version = "0.3", default-features = false }
async-trait = "0.1.7"
err-derive = "0.2.3"
bytes = "0.6.0"
lru = "0.6"
-rand = "0.5.5"
+
+sodiumoxide = { git = "https://github.com/Dhole/sodiumoxidez", branch = "extra" }
+#kuska-handshake = { path = "../handshake", features = ["default", "tokio_compat"] }
+kuska-handshake = { git = "https://github.com/kuska-ssb/handshake", branch = "master", features = ["default", "tokio_compat"] }