aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-10-12 13:07:34 +0200
committerAlex Auvolat <alex@adnab.me>2021-10-12 13:07:34 +0200
commit7753b789b7aca87db4db7aed20e79a41ecb0b225 (patch)
treef5b67a3d52736eb60d88cdd8772957ada62654fb /Cargo.toml
parent90f8fb28361cba1087a0e608e8a8deb6abb5bd39 (diff)
downloadnetapp-7753b789b7aca87db4db7aed20e79a41ecb0b225.tar.gz
netapp-7753b789b7aca87db4db7aed20e79a41ecb0b225.zip
Upgrade to tokio 1.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3f093f2..0a808ab 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "netapp"
-version = "0.1.2"
+version = "0.2.0"
authors = ["Alex Auvolat <alex@adnab.me>"]
edition = "2018"
license-file = "LICENSE"
@@ -20,16 +20,14 @@ basalt = ["lru", "rand"]
[dependencies]
async-std = { version = "1.5.0", default-features = false }
-tokio = { version = "0.2", default-features = false, features = ["net", "tcp", "rt-core", "rt-threaded", "sync", "time", "macros"] }
+tokio = { version = "1.0", default-features = false, features = ["net", "rt", "rt-multi-thread", "sync", "time", "macros"] }
serde = { version = "1.0", default-features = false, features = ["derive"] }
rmp-serde = "0.14.3"
hex = "0.4.2"
base64 = "0.12.1"
-structopt = { version = "0.3", default-features = false }
rand = { version = "0.5.5", optional = true }
-chrono = "0.4"
log = "0.4.8"
env_logger = "0.8"
@@ -40,7 +38,11 @@ bytes = "0.6.0"
lru = { version = "0.6", optional = true }
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
-kuska-handshake = { version = "0.1.2", features = ["default", "tokio_compat"] }
+kuska-handshake = { version = "0.2.0", git = "https://github.com/Alexis211/handshake", branch = "tokio1.0", features = ["default", "tokio_compat"] }
+
+[dev-dependencies]
+structopt = { version = "0.3", default-features = false }
+chrono = "0.4"
[package.metadata.cargo-all-features]
skip_optional_dependencies = true