aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-10-12 14:51:28 +0200
committerAlex Auvolat <alex@adnab.me>2021-10-12 14:51:28 +0200
commita4069d703c63e9512a87df7f16c574711f960335 (patch)
treedac67bf63ba2c85c421d3d10b9dbf71d9d32e4e2 /Cargo.toml
parentb14515a422a04fa008e6c67f6465ead927c7b8ad (diff)
downloadnetapp-a4069d703c63e9512a87df7f16c574711f960335.tar.gz
netapp-a4069d703c63e9512a87df7f16c574711f960335.zip
Use tokio_util::compat instead of the one from kuska-handshake
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0a808ab..5f64a33 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,8 +19,9 @@ default = []
basalt = ["lru", "rand"]
[dependencies]
-async-std = { version = "1.5.0", default-features = false }
-tokio = { version = "1.0", default-features = false, features = ["net", "rt", "rt-multi-thread", "sync", "time", "macros"] }
+futures = "0.3.17"
+tokio = { version = "1.0", default-features = false, features = ["net", "rt", "rt-multi-thread", "sync", "time", "macros", "io-util"] }
+tokio-util = { version = "0.6.8", default-features = false, features = ["compat"] }
serde = { version = "1.0", default-features = false, features = ["derive"] }
rmp-serde = "0.14.3"
@@ -38,7 +39,7 @@ bytes = "0.6.0"
lru = { version = "0.6", optional = true }
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
-kuska-handshake = { version = "0.2.0", git = "https://github.com/Alexis211/handshake", branch = "tokio1.0", features = ["default", "tokio_compat"] }
+kuska-handshake = { version = "0.2.0", git = "https://github.com/Alexis211/handshake", branch = "tokio1.0", features = ["default", "async_std"] }
[dev-dependencies]
structopt = { version = "0.3", default-features = false }