aboutsummaryrefslogtreecommitdiff
path: root/app/cryptpad/build/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'app/cryptpad/build/shell.nix')
-rw-r--r--app/cryptpad/build/shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/app/cryptpad/build/shell.nix b/app/cryptpad/build/shell.nix
new file mode 100644
index 0000000..d47a050
--- /dev/null
+++ b/app/cryptpad/build/shell.nix
@@ -0,0 +1,13 @@
+let
+ common = import ./common.nix;
+ pkgs = import common.pkgsSrc {};
+ nodejs = pkgs.${common.nodejs};
+in
+ pkgs.mkShell {
+ buildInputs = [
+ nodejs
+ pkgs.nodePackages.npm
+ pkgs.nodePackages.bower
+ ];
+ }
+