aboutsummaryrefslogtreecommitdiff
path: root/app/cryptpad/build/docker.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-05-05 17:45:15 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-05-05 17:45:15 +0200
commitf0ead6efed2ce7078302b825ad6b98fbbeebc693 (patch)
treebf179638e23db1842284430970732034600c0a1c /app/cryptpad/build/docker.nix
parentf27636dd14cc06b84f1564f48c148be7394540b3 (diff)
downloadinfrastructure-f0ead6efed2ce7078302b825ad6b98fbbeebc693.tar.gz
infrastructure-f0ead6efed2ce7078302b825ad6b98fbbeebc693.zip
WIP Cryptpad packaging
Diffstat (limited to 'app/cryptpad/build/docker.nix')
-rw-r--r--app/cryptpad/build/docker.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/app/cryptpad/build/docker.nix b/app/cryptpad/build/docker.nix
new file mode 100644
index 0000000..818bbd1
--- /dev/null
+++ b/app/cryptpad/build/docker.nix
@@ -0,0 +1,11 @@
+let
+ common = import ./common.nix;
+ app = import ./default.nix;
+ pkgs = import common.pkgsSrc {};
+in
+ pkgs.dockerTools.buildImage {
+ name = "superboum/cryptpad";
+ config = {
+ Cmd = [ "${app}/bin/backup-psql" ];
+ };
+ }