diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 13 |
1 files changed, 7 insertions, 6 deletions
@@ -2,22 +2,23 @@ description = "A simple LDAP web interface for Bottin"; inputs.nixpkgs.url = - "github:nixos/nixpkgs/0244e143dc943bcf661fdaf581f01eb0f5000fcf"; + "github:nixos/nixpkgs/f758d66c9cc3011f5327f8583908a7803cc019b1"; inputs.gomod2nix.url = - "github:tweag/gomod2nix/40d32f82fc60d66402eb0972e6e368aeab3faf58"; + "github:tweag/gomod2nix/f95720e89af6165c8c0aa77f180461fe786f3c21"; outputs = { self, nixpkgs, gomod2nix }: let pkgs = import nixpkgs { system = "x86_64-linux"; overlays = [ - (self: super: { + (import "${gomod2nix}/overlay.nix") + /*(self: super: { gomod = super.callPackage "${gomod2nix}/builder/" { }; - }) + })*/ ]; }; src = ./.; - bottin = pkgs.gomod.buildGoApplication { + bottin = pkgs.buildGoApplication { pname = "guichet"; version = "0.1.0"; src = src; @@ -41,6 +42,6 @@ packages.x86_64-linux.bottin = bottin; packages.x86_64-linux.default = bottin; - devShell.x86_64-linux = pkgs.mkShell { nativeBuildInputs = [ pkgs.go ]; }; + devShell.x86_64-linux = pkgs.mkShell { nativeBuildInputs = [ pkgs.go pkgs.gomod2nix ]; }; }; } |