diff options
author | Alex Auvolat <alex@adnab.me> | 2023-02-08 13:11:43 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2023-02-08 13:11:43 +0100 |
commit | 670123df38608c98eadc482b9778ddfffe8560c7 (patch) | |
tree | 6b18562f502100a3dc80615a1b0b7d7c5203852f /flake.nix | |
parent | cd415325729fddea26c816291bb33171b9cc4879 (diff) | |
download | guichet-670123df38608c98eadc482b9778ddfffe8560c7.tar.gz guichet-670123df38608c98eadc482b9778ddfffe8560c7.zip |
First iteration on mailing list administration interface
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 65 |
1 files changed, 33 insertions, 32 deletions
@@ -1,43 +1,44 @@ { description = "A simple LDAP web interface for Bottin"; - inputs.nixpkgs.url = "github:nixos/nixpkgs/0244e143dc943bcf661fdaf581f01eb0f5000fcf"; - inputs.gomod2nix.url = "github:tweag/gomod2nix/40d32f82fc60d66402eb0972e6e368aeab3faf58"; + inputs.nixpkgs.url = + "github:nixos/nixpkgs/0244e143dc943bcf661fdaf581f01eb0f5000fcf"; + inputs.gomod2nix.url = + "github:tweag/gomod2nix/40d32f82fc60d66402eb0972e6e368aeab3faf58"; outputs = { self, nixpkgs, gomod2nix }: - let - pkgs = import nixpkgs { - system = "x86_64-linux"; - overlays = [ - (self: super: { - gomod = super.callPackage "${gomod2nix}/builder/" { }; - }) - ]; - }; - src = ./.; - bottin = pkgs.gomod.buildGoApplication { - pname = "guichet"; - version = "0.1.0"; - src = src; - modules = ./gomod2nix.toml; + let + pkgs = import nixpkgs { + system = "x86_64-linux"; + overlays = [ + (self: super: { + gomod = super.callPackage "${gomod2nix}/builder/" { }; + }) + ]; + }; + src = ./.; + bottin = pkgs.gomod.buildGoApplication { + pname = "guichet"; + version = "0.1.0"; + src = src; + modules = ./gomod2nix.toml; - CGO_ENABLED=0; + CGO_ENABLED = 0; - ldflags = [ - "-X main.templatePath=${src + "/templates"}" - "-X main.staticPath=${src + "/static"}" - ]; + ldflags = [ + "-X main.templatePath=${src + "/templates"}" + "-X main.staticPath=${src + "/static"}" + ]; - meta = with pkgs.lib; { - description = "A simple LDAP web interface for Bottin"; - homepage = "https://git.deuxfleurs.fr/Deuxfleurs/guichet"; - license = licenses.gpl3Plus; - platforms = platforms.linux; + meta = with pkgs.lib; { + description = "A simple LDAP web interface for Bottin"; + homepage = "https://git.deuxfleurs.fr/Deuxfleurs/guichet"; + license = licenses.gpl3Plus; + platforms = platforms.linux; + }; }; + in { + packages.x86_64-linux.bottin = bottin; + devShell.x86_64-linux = pkgs.mkShell { nativeBuildInputs = [ pkgs.go ]; }; }; - in - { - packages.x86_64-linux.bottin = bottin; - packages.x86_64-linux.default = self.packages.x86_64-linux.bottin; - }; } |