aboutsummaryrefslogtreecommitdiff
path: root/src/web/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/web/Cargo.toml')
-rw-r--r--src/web/Cargo.toml23
1 files changed, 12 insertions, 11 deletions
diff --git a/src/web/Cargo.toml b/src/web/Cargo.toml
index 5cc8683c..6c3b3a9a 100644
--- a/src/web/Cargo.toml
+++ b/src/web/Cargo.toml
@@ -1,9 +1,9 @@
[package]
name = "garage_web"
-version = "0.1.1"
+version = "0.2.1"
authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"]
edition = "2018"
-license = "GPL-3.0"
+license = "AGPL-3.0"
description = "S3-like website endpoint crate for the Garage object store"
repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
@@ -13,16 +13,17 @@ path = "lib.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-garage_util = { version = "0.1.1", path = "../util" }
-garage_table = { version = "0.1.1", path = "../table" }
-garage_model = { version = "0.1.1", path = "../model" }
-garage_api = { version = "0.1.1", path = "../api" }
+garage_api = { version = "0.2.1", path = "../api" }
+garage_model = { version = "0.2.1", path = "../model" }
+garage_util = { version = "0.2.1", path = "../util" }
+garage_table = { version = "0.2.1", path = "../table" }
-err-derive = "0.2.3"
+err-derive = "0.3"
+idna = "0.2"
log = "0.4"
+percent-encoding = "2.1.0"
+
futures = "0.3"
+
http = "0.2"
-hyper = "0.13"
-percent-encoding = "2.1.0"
-roxmltree = "0.11"
-idna = "0.2"
+hyper = "0.14"