aboutsummaryrefslogtreecommitdiff
path: root/src/util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Cargo.toml')
-rw-r--r--src/util/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/util/Cargo.toml b/src/util/Cargo.toml
new file mode 100644
index 00000000..6f61a586
--- /dev/null
+++ b/src/util/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "garage_util"
+version = "0.1.0"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+rand = "0.7"
+hex = "0.3"
+sha2 = "0.8"
+err-derive = "0.2.3"
+log = "0.4"
+
+sled = "0.31"
+
+toml = "0.5"
+rmp-serde = "0.14.3"
+serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
+serde_json = "1.0"
+
+futures = "0.3"
+futures-util = "0.3"
+tokio = { version = "0.2", default-features = false, features = ["rt-core", "rt-threaded", "io-driver", "net", "tcp", "time", "macros", "sync", "signal", "fs"] }
+
+http = "0.2"
+hyper = "0.13"
+rustls = "0.17"
+webpki = "0.21"
+
+