aboutsummaryrefslogtreecommitdiff
path: root/src/model/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/model/Cargo.toml')
-rw-r--r--src/model/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/model/Cargo.toml b/src/model/Cargo.toml
new file mode 100644
index 00000000..be3b1449
--- /dev/null
+++ b/src/model/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "garage_model"
+version = "0.1.0"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_util = { path = "../util" }
+garage_rpc = { path = "../rpc" }
+garage_table = { path = "../table" }
+
+bytes = "0.4"
+rand = "0.7"
+hex = "0.3"
+sha2 = "0.8"
+arc-swap = "0.4"
+log = "0.4"
+
+sled = "0.31"
+
+rmp-serde = "0.14.3"
+serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
+serde_bytes = "0.11"
+
+async-trait = "0.1.30"
+futures = "0.3"
+futures-util = "0.3"
+tokio = { version = "0.2", default-features = false, features = ["rt-core", "rt-threaded", "io-driver", "net", "tcp", "time", "macros", "sync", "signal", "fs"] }
+