aboutsummaryrefslogtreecommitdiff
path: root/src/api/common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/api/common/Cargo.toml')
-rw-r--r--src/api/common/Cargo.toml27
1 files changed, 0 insertions, 27 deletions
diff --git a/src/api/common/Cargo.toml b/src/api/common/Cargo.toml
index 7be16a09..eea43efe 100644
--- a/src/api/common/Cargo.toml
+++ b/src/api/common/Cargo.toml
@@ -16,56 +16,29 @@ path = "lib.rs"
[dependencies]
garage_model.workspace = true
garage_table.workspace = true
-garage_block.workspace = true
-garage_net.workspace = true
garage_util.workspace = true
-garage_rpc.workspace = true
-
-aes-gcm.workspace = true
-argon2.workspace = true
-async-compression.workspace = true
async-trait.workspace = true
-base64.workspace = true
bytes.workspace = true
chrono.workspace = true
-crc32fast.workspace = true
-crc32c.workspace = true
crypto-common.workspace = true
err-derive.workspace = true
hex.workspace = true
hmac.workspace = true
idna.workspace = true
tracing.workspace = true
-md-5.workspace = true
nom.workspace = true
pin-project.workspace = true
-sha1.workspace = true
sha2.workspace = true
futures.workspace = true
-futures-util.workspace = true
tokio.workspace = true
-tokio-stream.workspace = true
-tokio-util.workspace = true
-
-form_urlencoded.workspace = true
http.workspace = true
-httpdate.workspace = true
-http-range.workspace = true
http-body-util.workspace = true
hyper = { workspace = true, default-features = false, features = ["server", "http1"] }
hyper-util.workspace = true
-multer.workspace = true
-percent-encoding.workspace = true
url.workspace = true
serde.workspace = true
-serde_bytes.workspace = true
serde_json.workspace = true
opentelemetry.workspace = true
-opentelemetry-prometheus = { workspace = true, optional = true }
-prometheus = { workspace = true, optional = true }
-
-[features]
-metrics = [ "opentelemetry-prometheus", "prometheus" ]