aboutsummaryrefslogtreecommitdiff
path: root/nix/manifest-tool.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/manifest-tool.nix')
-rw-r--r--nix/manifest-tool.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nix/manifest-tool.nix b/nix/manifest-tool.nix
new file mode 100644
index 00000000..182ccc0e
--- /dev/null
+++ b/nix/manifest-tool.nix
@@ -0,0 +1,23 @@
+pkgs:
+pkgs.buildGoModule rec {
+ pname = "manifest-tool";
+ version = "2.0.5";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "estesp";
+ repo = "manifest-tool";
+ rev = "v${version}";
+ sha256 = "hjCGKnE0yrlnF/VIzOwcDzmQX3Wft+21KCny/opqdLg=";
+ } + "/v2";
+
+ vendorSha256 = null;
+
+ checkPhase = "true";
+
+ meta = with pkgs.lib; {
+ description = "Command line tool to create and query container image manifest list/indexes";
+ homepage = "https://github.com/estesp/manifest-tool";
+ license = licenses.asl20;
+ platforms = platforms.linux;
+ };
+}