aboutsummaryrefslogtreecommitdiff
path: root/nix/kaniko.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/kaniko.nix')
-rw-r--r--nix/kaniko.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nix/kaniko.nix b/nix/kaniko.nix
new file mode 100644
index 00000000..140328b8
--- /dev/null
+++ b/nix/kaniko.nix
@@ -0,0 +1,23 @@
+pkgs:
+pkgs.buildGoModule rec {
+ pname = "kaniko";
+ version = "1.6.0";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "GoogleContainerTools";
+ repo = "kaniko";
+ rev = "v${version}";
+ sha256 = "1fnclr556avxay6pvgw5ya3xbxfnf2gv4njq2hr4fd6fcjyslq5h";
+ };
+
+ vendorSha256 = null;
+
+ checkPhase = "true";
+
+ meta = with pkgs.lib; {
+ description = "kaniko is a tool to build container images from a Dockerfile, inside a container or Kubernetes cluster.";
+ homepage = "https://github.com/GoogleContainerTools/kaniko";
+ license = licenses.asl20;
+ platforms = platforms.linux;
+ };
+}