aboutsummaryrefslogtreecommitdiff
path: root/doc/talks/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'doc/talks/shell.nix')
-rw-r--r--doc/talks/shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/talks/shell.nix b/doc/talks/shell.nix
new file mode 100644
index 00000000..161a61e1
--- /dev/null
+++ b/doc/talks/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> { } }:
+let
+ latex = (pkgs.texlive.combine {
+ inherit (pkgs.texlive)
+ scheme-basic
+ beamer amsmath mathtools breqn
+ environ
+ multirow graphics import adjustbox tabu vwcol stmaryrd ulem ragged2e
+ dvisvgm dvipng wrapfig hyperref capt-of;
+ });
+in pkgs.mkShell { nativeBuildInputs = [ pkgs.gnumake latex ]; }
+