aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix270
1 files changed, 201 insertions, 69 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 0a4ca99a..cd485416 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -34,7 +34,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "8112e20b0e356bed77a9769600c2b2952662ec8af9548eecf8a2d46fe8433189";
+ nixifiedLockHash = "c3296a54f1c6f385e0d4a4a937734f1fe0fee4405b44d7462249d72675f7ac40";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -58,17 +58,17 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.9.3";
- garage_util = rustPackages.unknown.garage_util."0.9.3";
- garage_net = rustPackages.unknown.garage_net."0.9.3";
- garage_rpc = rustPackages.unknown.garage_rpc."0.9.3";
+ garage_db = rustPackages.unknown.garage_db."0.10.0";
+ garage_util = rustPackages.unknown.garage_util."0.10.0";
+ garage_net = rustPackages.unknown.garage_net."0.10.0";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.10.0";
format_table = rustPackages.unknown.format_table."0.1.1";
- garage_table = rustPackages.unknown.garage_table."0.9.3";
- garage_block = rustPackages.unknown.garage_block."0.9.3";
- garage_model = rustPackages.unknown.garage_model."0.9.3";
- garage_api = rustPackages.unknown.garage_api."0.9.3";
- garage_web = rustPackages.unknown.garage_web."0.9.3";
- garage = rustPackages.unknown.garage."0.9.3";
+ garage_table = rustPackages.unknown.garage_table."0.10.0";
+ garage_block = rustPackages.unknown.garage_block."0.10.0";
+ garage_model = rustPackages.unknown.garage_model."0.10.0";
+ garage_api = rustPackages.unknown.garage_api."0.10.0";
+ garage_web = rustPackages.unknown.garage_web."0.10.0";
+ garage = rustPackages.unknown.garage."0.10.0";
k2v-client = rustPackages.unknown.k2v-client."0.0.4";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.21.0" = overridableMkRustCrate (profileName: rec {
@@ -88,6 +88,58 @@ in
src = fetchCratesIo { inherit name version; sha256 = "f26201604c87b1e01bd3d98f8d5d9a8fcbb815e8cedb41ffccbeb4bf593a35fe"; };
});
+ "registry+https://github.com/rust-lang/crates.io-index".aead."0.5.2" = overridableMkRustCrate (profileName: rec {
+ name = "aead";
+ version = "0.5.2";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "d122413f284cf2d62fb1b7db97e02edb8cda96d769b16e443a4f6195e35662b0"; };
+ features = builtins.concatLists [
+ [ "alloc" ]
+ [ "getrandom" ]
+ [ "rand_core" ]
+ [ "stream" ]
+ ];
+ dependencies = {
+ crypto_common = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".crypto-common."0.1.6" { inherit profileName; }).out;
+ generic_array = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".generic-array."0.14.7" { inherit profileName; }).out;
+ };
+ });
+
+ "registry+https://github.com/rust-lang/crates.io-index".aes."0.8.4" = overridableMkRustCrate (profileName: rec {
+ name = "aes";
+ version = "0.8.4";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "b169f7a6d4742236a0a00c541b845991d0ac43e546831af1249753ab4c3aa3a0"; };
+ dependencies = {
+ cfg_if = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cfg-if."1.0.0" { inherit profileName; }).out;
+ cipher = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cipher."0.4.4" { inherit profileName; }).out;
+ ${ if hostPlatform.parsed.cpu.name == "aarch64" || hostPlatform.parsed.cpu.name == "x86_64" || hostPlatform.parsed.cpu.name == "i686" then "cpufeatures" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cpufeatures."0.2.12" { inherit profileName; }).out;
+ };
+ });
+
+ "registry+https://github.com/rust-lang/crates.io-index".aes-gcm."0.10.3" = overridableMkRustCrate (profileName: rec {
+ name = "aes-gcm";
+ version = "0.10.3";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "831010a0f742e1209b3bcea8fab6a8e149051ba6099432c8cb2cc117dec3ead1"; };
+ features = builtins.concatLists [
+ [ "aes" ]
+ [ "alloc" ]
+ [ "default" ]
+ [ "getrandom" ]
+ [ "rand_core" ]
+ [ "stream" ]
+ ];
+ dependencies = {
+ aead = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".aead."0.5.2" { inherit profileName; }).out;
+ aes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".aes."0.8.4" { inherit profileName; }).out;
+ cipher = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cipher."0.4.4" { inherit profileName; }).out;
+ ctr = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".ctr."0.9.2" { inherit profileName; }).out;
+ ghash = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".ghash."0.5.1" { inherit profileName; }).out;
+ subtle = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".subtle."2.5.0" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".ahash."0.8.7" = overridableMkRustCrate (profileName: rec {
name = "ahash";
version = "0.8.7";
@@ -1085,6 +1137,17 @@ in
};
});
+ "registry+https://github.com/rust-lang/crates.io-index".cipher."0.4.4" = overridableMkRustCrate (profileName: rec {
+ name = "cipher";
+ version = "0.4.4";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "773f3b9af64447d2ce9850330c473515014aa235e6a783b02db81ff39e4a3dad"; };
+ dependencies = {
+ crypto_common = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".crypto-common."0.1.6" { inherit profileName; }).out;
+ inout = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".inout."0.1.3" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".clap."2.34.0" = overridableMkRustCrate (profileName: rec {
name = "clap";
version = "2.34.0";
@@ -1333,14 +1396,27 @@ in
registry = "registry+https://github.com/rust-lang/crates.io-index";
src = fetchCratesIo { inherit name version; sha256 = "1bfb12502f3fc46cca1bb51ac28df9d618d813cdc3d2f25b9fe775a34af26bb3"; };
features = builtins.concatLists [
+ [ "getrandom" ]
+ [ "rand_core" ]
[ "std" ]
];
dependencies = {
generic_array = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".generic-array."0.14.7" { inherit profileName; }).out;
+ rand_core = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand_core."0.6.4" { inherit profileName; }).out;
typenum = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".typenum."1.17.0" { inherit profileName; }).out;
};
});
+ "registry+https://github.com/rust-lang/crates.io-index".ctr."0.9.2" = overridableMkRustCrate (profileName: rec {
+ name = "ctr";
+ version = "0.9.2";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "0369ee1ad671834580515889b80f2ea915f23b8be8d0daa4bbaf2ac5c7590835"; };
+ dependencies = {
+ cipher = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cipher."0.4.4" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".darling."0.20.5" = overridableMkRustCrate (profileName: rec {
name = "darling";
version = "0.20.5";
@@ -1871,9 +1947,9 @@ in
};
});
- "unknown".garage."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1900,15 +1976,15 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.3" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.3" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.9.3" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.10.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.10.0" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.9" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
@@ -1946,9 +2022,9 @@ in
};
});
- "unknown".garage_api."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1958,7 +2034,9 @@ in
(lib.optional (rootFeatures' ? "garage/default" || rootFeatures' ? "garage/metrics" || rootFeatures' ? "garage_api/metrics" || rootFeatures' ? "garage_api/prometheus") "prometheus")
];
dependencies = {
+ aes_gcm = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".aes-gcm."0.10.3" { inherit profileName; }).out;
argon2 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".argon2."0.5.3" { inherit profileName; }).out;
+ async_compression = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".async-compression."0.4.6" { inherit profileName; }).out;
async_trait = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".async-trait."0.1.77" { profileName = "__noProfile"; }).out;
base64 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".base64."0.21.7" { inherit profileName; }).out;
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.5.0" { inherit profileName; }).out;
@@ -1968,12 +2046,12 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.2.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -1999,14 +2077,15 @@ in
sha2 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".sha2."0.10.8" { inherit profileName; }).out;
tokio = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".tokio."1.36.0" { inherit profileName; }).out;
tokio_stream = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".tokio-stream."0.1.14" { inherit profileName; }).out;
+ tokio_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".tokio-util."0.7.10" { inherit profileName; }).out;
tracing = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".tracing."0.1.40" { inherit profileName; }).out;
url = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".url."2.5.0" { inherit profileName; }).out;
};
});
- "unknown".garage_block."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -2020,11 +2099,11 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -2037,9 +2116,9 @@ in
};
});
- "unknown".garage_db."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -2064,9 +2143,9 @@ in
};
});
- "unknown".garage_model."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -2085,13 +2164,14 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.3" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
+ http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
serde = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".serde."1.0.196" { inherit profileName; }).out;
@@ -2102,9 +2182,9 @@ in
};
});
- "unknown".garage_net."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_net."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_net";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/net");
features = builtins.concatLists [
@@ -2139,9 +2219,9 @@ in
};
});
- "unknown".garage_rpc."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -2163,9 +2243,9 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
itertools = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".itertools."0.12.1" { inherit profileName; }).out;
@@ -2187,9 +2267,9 @@ in
};
});
- "unknown".garage_table."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -2198,9 +2278,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.5.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2212,9 +2292,9 @@ in
};
});
- "unknown".garage_util."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -2230,8 +2310,8 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -2256,18 +2336,18 @@ in
};
});
- "unknown".garage_web."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.9.3";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
http_body_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http-body-util."0.1.0" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."1.1.0" { inherit profileName; }).out;
@@ -2321,6 +2401,17 @@ in
};
});
+ "registry+https://github.com/rust-lang/crates.io-index".ghash."0.5.1" = overridableMkRustCrate (profileName: rec {
+ name = "ghash";
+ version = "0.5.1";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "f0d8a4362ccb29cb0b265253fb0a2728f592895ee6854fd9bc13f2ffda266ff1"; };
+ dependencies = {
+ opaque_debug = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opaque-debug."0.3.1" { inherit profileName; }).out;
+ polyval = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".polyval."0.6.2" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".gimli."0.28.1" = overridableMkRustCrate (profileName: rec {
name = "gimli";
version = "0.28.1";
@@ -2928,6 +3019,16 @@ in
};
});
+ "registry+https://github.com/rust-lang/crates.io-index".inout."0.1.3" = overridableMkRustCrate (profileName: rec {
+ name = "inout";
+ version = "0.1.3";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "a0c10553d664a4d0bcff9f4215d0aac67a639cc68ef660840afe309b807bc9f5"; };
+ dependencies = {
+ generic_array = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".generic-array."0.14.7" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".instant."0.1.12" = overridableMkRustCrate (profileName: rec {
name = "instant";
version = "0.1.12";
@@ -3777,6 +3878,13 @@ in
];
});
+ "registry+https://github.com/rust-lang/crates.io-index".opaque-debug."0.3.1" = overridableMkRustCrate (profileName: rec {
+ name = "opaque-debug";
+ version = "0.3.1";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "c08d65885ee38876c4f86fa503fb49d7b507c2b62552df7c70b2fce627e06381"; };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".openssl-probe."0.1.5" = overridableMkRustCrate (profileName: rec {
name = "openssl-probe";
version = "0.1.5";
@@ -4236,6 +4344,19 @@ in
};
});
+ "registry+https://github.com/rust-lang/crates.io-index".polyval."0.6.2" = overridableMkRustCrate (profileName: rec {
+ name = "polyval";
+ version = "0.6.2";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "9d1fe60d06143b2430aa532c94cfe9e29783047f06c0d7fd359a9a51b729fa25"; };
+ dependencies = {
+ cfg_if = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cfg-if."1.0.0" { inherit profileName; }).out;
+ ${ if hostPlatform.parsed.cpu.name == "aarch64" || hostPlatform.parsed.cpu.name == "x86_64" || hostPlatform.parsed.cpu.name == "i686" then "cpufeatures" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".cpufeatures."0.2.12" { inherit profileName; }).out;
+ opaque_debug = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opaque-debug."0.3.1" { inherit profileName; }).out;
+ universal_hash = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".universal-hash."0.5.1" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".powerfmt."0.2.0" = overridableMkRustCrate (profileName: rec {
name = "powerfmt";
version = "0.2.0";
@@ -6314,6 +6435,17 @@ in
];
});
+ "registry+https://github.com/rust-lang/crates.io-index".universal-hash."0.5.1" = overridableMkRustCrate (profileName: rec {
+ name = "universal-hash";
+ version = "0.5.1";
+ registry = "registry+https://github.com/rust-lang/crates.io-index";
+ src = fetchCratesIo { inherit name version; sha256 = "fc1de2c688dc15305988b563c3854064043356019f97a4b46276fe734c4f07ea"; };
+ dependencies = {
+ crypto_common = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".crypto-common."0.1.6" { inherit profileName; }).out;
+ subtle = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".subtle."2.5.0" { inherit profileName; }).out;
+ };
+ });
+
"registry+https://github.com/rust-lang/crates.io-index".unsafe-libyaml."0.2.10" = overridableMkRustCrate (profileName: rec {
name = "unsafe-libyaml";
version = "0.2.10";