aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix138
1 files changed, 69 insertions, 69 deletions
diff --git a/Cargo.nix b/Cargo.nix
index dfe01bfe..0acd15bd 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -34,7 +34,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "9377d18da3b48658f9d8b2070db135db2d9ac6d9c692d6656948b765348498cc";
+ nixifiedLockHash = "78a919892c20922859f8146234cfb36542303861f757e6ebb11d010965285f04";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -58,17 +58,17 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.9.1";
- garage_util = rustPackages.unknown.garage_util."0.9.1";
- garage_net = rustPackages.unknown.garage_net."0.9.1";
- garage_rpc = rustPackages.unknown.garage_rpc."0.9.1";
+ garage_db = rustPackages.unknown.garage_db."0.10.0";
+ garage_util = rustPackages.unknown.garage_util."0.10.0";
+ garage_net = rustPackages.unknown.garage_net."0.10.0";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.10.0";
format_table = rustPackages.unknown.format_table."0.1.1";
- garage_table = rustPackages.unknown.garage_table."0.9.1";
- garage_block = rustPackages.unknown.garage_block."0.9.1";
- garage_model = rustPackages.unknown.garage_model."0.9.1";
- garage_api = rustPackages.unknown.garage_api."0.9.1";
- garage_web = rustPackages.unknown.garage_web."0.9.1";
- garage = rustPackages.unknown.garage."0.9.1";
+ garage_table = rustPackages.unknown.garage_table."0.10.0";
+ garage_block = rustPackages.unknown.garage_block."0.10.0";
+ garage_model = rustPackages.unknown.garage_model."0.10.0";
+ garage_api = rustPackages.unknown.garage_api."0.10.0";
+ garage_web = rustPackages.unknown.garage_web."0.10.0";
+ garage = rustPackages.unknown.garage."0.10.0";
k2v-client = rustPackages.unknown.k2v-client."0.0.4";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.21.0" = overridableMkRustCrate (profileName: rec {
@@ -1852,9 +1852,9 @@ in
};
});
- "unknown".garage."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1881,15 +1881,15 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.1" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.1" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.9.1" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.10.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.10.0" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.9" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
@@ -1927,9 +1927,9 @@ in
};
});
- "unknown".garage_api."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1948,12 +1948,12 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.2.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -1984,9 +1984,9 @@ in
};
});
- "unknown".garage_block."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -2000,11 +2000,11 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -2017,9 +2017,9 @@ in
};
});
- "unknown".garage_db."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -2044,9 +2044,9 @@ in
};
});
- "unknown".garage_model."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -2065,12 +2065,12 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.1" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -2082,9 +2082,9 @@ in
};
});
- "unknown".garage_net."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_net."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_net";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/net");
features = builtins.concatLists [
@@ -2119,9 +2119,9 @@ in
};
});
- "unknown".garage_rpc."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -2143,9 +2143,9 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
itertools = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".itertools."0.12.1" { inherit profileName; }).out;
@@ -2167,9 +2167,9 @@ in
};
});
- "unknown".garage_table."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -2178,9 +2178,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.5.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2192,9 +2192,9 @@ in
};
});
- "unknown".garage_util."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -2210,8 +2210,8 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -2236,18 +2236,18 @@ in
};
});
- "unknown".garage_web."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.9.1";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
http_body_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http-body-util."0.1.0" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."1.1.0" { inherit profileName; }).out;