aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix120
1 files changed, 60 insertions, 60 deletions
diff --git a/Cargo.nix b/Cargo.nix
index a67751dd..14e5c260 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -32,7 +32,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "d36a8590fdf6eeb128a5a852d55945b595d5830291ad0aca95a21dcc1fab8681";
+ nixifiedLockHash = "af19dd561f2ce73d1f609040c1ebdf74420974d96959016da98d44b0e347f013";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -56,15 +56,15 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.8.1";
- garage_util = rustPackages.unknown.garage_util."0.8.1";
- garage_rpc = rustPackages.unknown.garage_rpc."0.8.1";
- garage_table = rustPackages.unknown.garage_table."0.8.1";
- garage_block = rustPackages.unknown.garage_block."0.8.1";
- garage_model = rustPackages.unknown.garage_model."0.8.1";
- garage_api = rustPackages.unknown.garage_api."0.8.1";
- garage_web = rustPackages.unknown.garage_web."0.8.1";
- garage = rustPackages.unknown.garage."0.8.1";
+ garage_db = rustPackages.unknown.garage_db."0.8.2";
+ garage_util = rustPackages.unknown.garage_util."0.8.2";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.8.2";
+ garage_table = rustPackages.unknown.garage_table."0.8.2";
+ garage_block = rustPackages.unknown.garage_block."0.8.2";
+ garage_model = rustPackages.unknown.garage_model."0.8.2";
+ garage_api = rustPackages.unknown.garage_api."0.8.2";
+ garage_web = rustPackages.unknown.garage_web."0.8.2";
+ garage = rustPackages.unknown.garage."0.8.2";
k2v-client = rustPackages.unknown.k2v-client."0.1.1";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.19.0" = overridableMkRustCrate (profileName: rec {
@@ -1531,9 +1531,9 @@ in
};
});
- "unknown".garage."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1559,14 +1559,14 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.1.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.25" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.8.1" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.1" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.8.1" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.8.2" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.2" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.2" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.8.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
netapp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".netapp."0.5.2" { inherit profileName; }).out;
@@ -1599,9 +1599,9 @@ in
};
});
- "unknown".garage_api."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1620,11 +1620,11 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.1.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.25" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.2" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
@@ -1653,9 +1653,9 @@ in
};
});
- "unknown".garage_block."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -1668,10 +1668,10 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.25" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -1684,9 +1684,9 @@ in
};
});
- "unknown".garage_db."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -1716,9 +1716,9 @@ in
};
});
- "unknown".garage_model."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -1736,11 +1736,11 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.25" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.1" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.2" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
netapp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".netapp."0.5.2" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -1753,9 +1753,9 @@ in
};
});
- "unknown".garage_rpc."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -1775,7 +1775,7 @@ in
${ if rootFeatures' ? "garage/consul-discovery" || rootFeatures' ? "garage_rpc/consul-discovery" || rootFeatures' ? "garage_rpc/err-derive" then "err_derive" else null } = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.25" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.2.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
${ if rootFeatures' ? "garage/kubernetes-discovery" || rootFeatures' ? "garage_rpc/k8s-openapi" || rootFeatures' ? "garage_rpc/kubernetes-discovery" then "k8s_openapi" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".k8s-openapi."0.16.0" { inherit profileName; }).out;
@@ -1797,9 +1797,9 @@ in
};
});
- "unknown".garage_table."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -1808,9 +1808,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.25" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -1822,9 +1822,9 @@ in
};
});
- "unknown".garage_util."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -1839,7 +1839,7 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.6" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.2" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.5" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
@@ -1866,18 +1866,18 @@ in
};
});
- "unknown".garage_web."0.8.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.8.2" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.8.1";
+ version = "0.8.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.25" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.8.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.8.2" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."0.14.23" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2555,7 +2555,7 @@ in
dependencies = {
base64 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".base64."0.21.0" { inherit profileName; }).out;
${ if rootFeatures' ? "k2v-client/clap" || rootFeatures' ? "k2v-client/cli" then "clap" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".clap."4.1.4" { inherit profileName; }).out;
- ${ if rootFeatures' ? "k2v-client/cli" || rootFeatures' ? "k2v-client/garage_util" then "garage_util" else null } = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ ${ if rootFeatures' ? "k2v-client/cli" || rootFeatures' ? "k2v-client/garage_util" then "garage_util" else null } = (rustPackages."unknown".garage_util."0.8.2" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
hyper_rustls = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper-rustls."0.23.2" { inherit profileName; }).out;
log = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".log."0.4.17" { inherit profileName; }).out;