aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix120
1 files changed, 60 insertions, 60 deletions
diff --git a/Cargo.nix b/Cargo.nix
index cd8270b6..ab983987 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -33,7 +33,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "1a87886681a3ef0b83c95addc26674a538b8a93d35bc80db8998e1fcd0821f6c";
+ nixifiedLockHash = "9946c45969e70c13413d3474740963f4cdb2a8a00199daa23a1bd152c186b319";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -57,16 +57,16 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.9.0";
- garage_util = rustPackages.unknown.garage_util."0.9.0";
- garage_rpc = rustPackages.unknown.garage_rpc."0.9.0";
+ garage_db = rustPackages.unknown.garage_db."0.10.0";
+ garage_util = rustPackages.unknown.garage_util."0.10.0";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.10.0";
format_table = rustPackages.unknown.format_table."0.1.1";
- garage_table = rustPackages.unknown.garage_table."0.9.0";
- garage_block = rustPackages.unknown.garage_block."0.9.0";
- garage_model = rustPackages.unknown.garage_model."0.9.0";
- garage_api = rustPackages.unknown.garage_api."0.9.0";
- garage_web = rustPackages.unknown.garage_web."0.9.0";
- garage = rustPackages.unknown.garage."0.9.0";
+ garage_table = rustPackages.unknown.garage_table."0.10.0";
+ garage_block = rustPackages.unknown.garage_block."0.10.0";
+ garage_model = rustPackages.unknown.garage_model."0.10.0";
+ garage_api = rustPackages.unknown.garage_api."0.10.0";
+ garage_web = rustPackages.unknown.garage_web."0.10.0";
+ garage = rustPackages.unknown.garage."0.10.0";
k2v-client = rustPackages.unknown.k2v-client."0.0.4";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.21.0" = overridableMkRustCrate (profileName: rec {
@@ -1705,9 +1705,9 @@ in
};
});
- "unknown".garage."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1734,14 +1734,14 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.0" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.0" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.0" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.9.0" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.10.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.10.0" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.5" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
@@ -1777,9 +1777,9 @@ in
};
});
- "unknown".garage_api."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1798,11 +1798,11 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.2.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.0" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
@@ -1832,9 +1832,9 @@ in
};
});
- "unknown".garage_block."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -1848,10 +1848,10 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -1864,9 +1864,9 @@ in
};
});
- "unknown".garage_db."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -1896,9 +1896,9 @@ in
};
});
- "unknown".garage_model."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -1917,11 +1917,11 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.0" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.10.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
netapp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".netapp."0.10.0" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -1934,9 +1934,9 @@ in
};
});
- "unknown".garage_rpc."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -1958,8 +1958,8 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
itertools = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".itertools."0.10.5" { inherit profileName; }).out;
@@ -1982,9 +1982,9 @@ in
};
});
- "unknown".garage_table."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -1993,9 +1993,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.4.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2007,9 +2007,9 @@ in
};
});
- "unknown".garage_util."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -2025,7 +2025,7 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.10.0" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
@@ -2051,18 +2051,18 @@ in
};
});
- "unknown".garage_web."0.9.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.10.0" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.9.0";
+ version = "0.10.0";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.0" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.0" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.10.0" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.10.0" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.10.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.10.0" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."0.14.27" { inherit profileName; }).out;
hyperlocal = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyperlocal."0.8.0" { inherit profileName; }).out;