aboutsummaryrefslogtreecommitdiff
path: root/src/web/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2021-01-15 17:49:49 +0100
committerAlex <alex@adnab.me>2021-01-15 17:49:49 +0100
commit97494b4a190cb16986b743ba1446968a6c180c6e (patch)
tree81edd9c3fab766e83ba8d8bba962aa68e1b911c3 /src/web/Cargo.toml
parent8956db2a81c3700b62c5208cff2ca4b0b124c328 (diff)
parent851893a3f299da9eeb0ef3c745be1f30164fd6cf (diff)
downloadgarage-97494b4a190cb16986b743ba1446968a6c180c6e.tar.gz
garage-97494b4a190cb16986b743ba1446968a6c180c6e.zip
Merge pull request 'Support website publishing' (#7) from feature/website into master
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/7
Diffstat (limited to 'src/web/Cargo.toml')
-rw-r--r--src/web/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/web/Cargo.toml b/src/web/Cargo.toml
new file mode 100644
index 00000000..751b9ace
--- /dev/null
+++ b/src/web/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "garage_web"
+version = "0.1.0"
+authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"]
+edition = "2018"
+license = "GPL-3.0"
+description = "S3-like website endpoint crate for the Garage object store"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_util = { version = "0.1", path = "../util" }
+garage_table = { version = "0.1.1", path = "../table" }
+garage_model = { version = "0.1.1", path = "../model" }
+garage_api = { version = "0.1.1", path = "../api" }
+
+err-derive = "0.2.3"
+log = "0.4"
+futures = "0.3"
+http = "0.2"
+hyper = "0.13"
+percent-encoding = "2.1.0"
+roxmltree = "0.11"
+idna = "0.2"