aboutsummaryrefslogtreecommitdiff
path: root/src/util/Cargo.toml
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-08-10 12:18:44 +0200
committerAlex Auvolat <alex@adnab.me>2022-08-29 17:54:03 +0200
commitcd5fa90c681c3be7e8835eb4043a55eb5cf01293 (patch)
tree7d0545f849e8548d95ebfae8cde1584b07713bd6 /src/util/Cargo.toml
parentd47af7b17300ad9db05ca787ff2038ab50c8b007 (diff)
downloadgarage-cd5fa90c681c3be7e8835eb4043a55eb5cf01293.tar.gz
garage-cd5fa90c681c3be7e8835eb4043a55eb5cf01293.zip
Configure structopt to report the right version
By default, structopt reports the value provided by the env var CARGO_PKG_VERSION, feeded by Cargo when reading Cargo.toml. However for Garage we use a versioning based on git, so we often report a version that is behind the real version. In this commit, we create garage_util::version::garage() that reports the right version and configure all structopt subcommands to call this function instead of using the env var.
Diffstat (limited to 'src/util/Cargo.toml')
-rw-r--r--src/util/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/util/Cargo.toml b/src/util/Cargo.toml
index 95cde531..8c15e6e4 100644
--- a/src/util/Cargo.toml
+++ b/src/util/Cargo.toml
@@ -21,6 +21,7 @@ hex = "0.4"
tracing = "0.1.30"
rand = "0.8"
sha2 = "0.9"
+git-version = "0.3.4"
sled = "0.34"
@@ -42,5 +43,6 @@ hyper = "0.14"
opentelemetry = { version = "0.17", features = [ "rt-tokio", "metrics", "trace" ] }
+
[features]
k2v = []