aboutsummaryrefslogtreecommitdiff
path: root/src/util/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2024-02-07 14:59:40 +0000
committerAlex <alex@adnab.me>2024-02-07 14:59:40 +0000
commit5d941e0100489fff552b59f0679a2a010403a21c (patch)
tree5c5cef9af72d48dd7347922341e43f0013380c60 /src/util/Cargo.toml
parentfeeb076b7f5db7fe6fdbe3d2903fae054cde6219 (diff)
parente011941964b1c1e0b90f85014d166d64a83ae8e2 (diff)
downloadgarage-5d941e0100489fff552b59f0679a2a010403a21c.tar.gz
garage-5d941e0100489fff552b59f0679a2a010403a21c.zip
Merge pull request 'Dependency upgrades: http, hyper, aws-sdk, smaller deps' (#703) from dep-upgrade-202402 into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/703
Diffstat (limited to 'src/util/Cargo.toml')
-rw-r--r--src/util/Cargo.toml64
1 files changed, 32 insertions, 32 deletions
diff --git a/src/util/Cargo.toml b/src/util/Cargo.toml
index 85317ec1..f4e53e1a 100644
--- a/src/util/Cargo.toml
+++ b/src/util/Cargo.toml
@@ -16,42 +16,42 @@ path = "lib.rs"
[dependencies]
garage_db.workspace = true
-arc-swap = "1.0"
-async-trait = "0.1"
-blake2 = "0.10"
-bytes = "1.0"
-bytesize = "1.2"
-digest = "0.10"
-err-derive = "0.3"
-hexdump = "0.1"
-xxhash-rust = { version = "0.8", default-features = false, features = ["xxh3"] }
-hex = "0.4"
-lazy_static = "1.4"
-tracing = "0.1"
-rand = "0.8"
-sha2 = "0.10"
-
-chrono = "0.4"
-rmp-serde = "1.1.2"
-serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
-serde_json = "1.0"
-toml = "0.6"
-
-futures = "0.3"
-tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
-
-netapp = "0.10"
-
-http = "0.2"
-hyper = "0.14"
-
-opentelemetry = { version = "0.17", features = [ "rt-tokio", "metrics", "trace" ] }
+arc-swap.workspace = true
+async-trait.workspace = true
+blake2.workspace = true
+bytes.workspace = true
+bytesize.workspace = true
+digest.workspace = true
+err-derive.workspace = true
+hexdump.workspace = true
+xxhash-rust.workspace = true
+hex.workspace = true
+lazy_static.workspace = true
+tracing.workspace = true
+rand.workspace = true
+sha2.workspace = true
+
+chrono.workspace = true
+rmp-serde.workspace = true
+serde.workspace = true
+serde_json.workspace = true
+toml.workspace = true
+
+futures.workspace = true
+tokio.workspace = true
+
+netapp.workspace = true
+
+http.workspace = true
+hyper.workspace = true
+
+opentelemetry.workspace = true
[build-dependencies]
-rustc_version = "0.4.0"
+rustc_version.workspace = true
[dev-dependencies]
-mktemp = "0.5"
+mktemp.workspace = true
[features]
k2v = []