aboutsummaryrefslogtreecommitdiff
path: root/src/util/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-07-18 17:18:47 +0200
committerAlex Auvolat <alex@adnab.me>2022-07-29 12:24:44 +0200
commit1b2e1296eb99630e969e585ede0424072adc2d0c (patch)
treee16b953e1f53e57c6efd11e688e955fa36cbb186 /src/util/Cargo.toml
parenta184f0d0b5f1d84524f7ba7302a4919567acec56 (diff)
downloadgarage-1b2e1296eb99630e969e585ede0424072adc2d0c.tar.gz
garage-1b2e1296eb99630e969e585ede0424072adc2d0c.zip
Compute hashes on dedicated threads
Diffstat (limited to 'src/util/Cargo.toml')
-rw-r--r--src/util/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/util/Cargo.toml b/src/util/Cargo.toml
index 57c70ffb..7d79f21a 100644
--- a/src/util/Cargo.toml
+++ b/src/util/Cargo.toml
@@ -18,12 +18,14 @@ garage_db = { version = "0.8.0", path = "../db" }
async-trait = "0.1"
blake2 = "0.9"
+bytes = "1.0"
+digest = "0.10"
err-derive = "0.3"
xxhash-rust = { version = "0.8", default-features = false, features = ["xxh3"] }
hex = "0.4"
tracing = "0.1.30"
rand = "0.8"
-sha2 = "0.9"
+sha2 = "0.10"
chrono = "0.4"
rmp-serde = "0.15"