aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-09-11 19:08:24 +0200
committerAlex Auvolat <alex@adnab.me>2023-09-11 19:08:24 +0200
commitd5bb50d738a5ac9a56ed137263b520b2d4135c29 (patch)
tree79d2d2836aea81c42e04331cec05af333205dd6f /src/rpc/Cargo.toml
parentfc635f7072e1def6e45123cd3abc4d267b555fc3 (diff)
downloadgarage-d5bb50d738a5ac9a56ed137263b520b2d4135c29.tar.gz
garage-d5bb50d738a5ac9a56ed137263b520b2d4135c29.zip
use statvfs instead of mount list to determine free data/meta space (fix #611)
Diffstat (limited to 'src/rpc/Cargo.toml')
-rw-r--r--src/rpc/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/rpc/Cargo.toml b/src/rpc/Cargo.toml
index 66004bb9..0cda723e 100644
--- a/src/rpc/Cargo.toml
+++ b/src/rpc/Cargo.toml
@@ -24,7 +24,7 @@ hex = "0.4"
tracing = "0.1"
rand = "0.8"
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
-systemstat = "0.2.3"
+nix = { version = "0.27", default-features = false, features = ["fs"] }
async-trait = "0.1.7"
serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }