aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/Cargo.toml
diff options
context:
space:
mode:
authorRoberto Hidalgo <un@rob.mx>2023-05-05 16:18:24 -0600
committerRoberto Hidalgo <un@rob.mx>2023-05-22 08:57:15 -0600
commit02ba9016ab6eca5bb4964549de002573d5a3a07a (patch)
tree85fc01db2fa60605d2016f253da3a64ae8ef75d9 /src/rpc/Cargo.toml
parent9d833bb7efc2c166036db38da89b0b5ac8f466fe (diff)
downloadgarage-02ba9016ab6eca5bb4964549de002573d5a3a07a.tar.gz
garage-02ba9016ab6eca5bb4964549de002573d5a3a07a.zip
register consul services against local agent instead of catalog api
Diffstat (limited to 'src/rpc/Cargo.toml')
-rw-r--r--src/rpc/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/rpc/Cargo.toml b/src/rpc/Cargo.toml
index f0fde7a7..d168e246 100644
--- a/src/rpc/Cargo.toml
+++ b/src/rpc/Cargo.toml
@@ -50,4 +50,5 @@ netapp = { version = "0.5.2", features = ["telemetry"] }
[features]
kubernetes-discovery = [ "kube", "k8s-openapi", "schemars" ]
consul-discovery = [ "reqwest", "err-derive" ]
+consul-service-discovery = [ "reqwest", "err-derive" ]
system-libs = [ "sodiumoxide/use-pkg-config" ]