aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <lx@deuxfleurs.fr>2025-01-31 18:47:30 +0100
committerAlex Auvolat <lx@deuxfleurs.fr>2025-01-31 18:47:30 +0100
commit4563313f87af4b7be26152164a5ce09a451da0d9 (patch)
tree1203788ebe76e71678691f9ff04029bd287d2488 /src/rpc/Cargo.toml
parentafa28706e5566737376f8448bcc548f780f0f57f (diff)
downloadgarage-4563313f87af4b7be26152164a5ce09a451da0d9.tar.gz
garage-4563313f87af4b7be26152164a5ce09a451da0d9.zip
use cargo-shear to remove many unused dependencies between crates
Diffstat (limited to 'src/rpc/Cargo.toml')
-rw-r--r--src/rpc/Cargo.toml4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/rpc/Cargo.toml b/src/rpc/Cargo.toml
index acde0911..fcc1c304 100644
--- a/src/rpc/Cargo.toml
+++ b/src/rpc/Cargo.toml
@@ -15,12 +15,10 @@ path = "lib.rs"
[dependencies]
format_table.workspace = true
-garage_db.workspace = true
garage_util.workspace = true
garage_net.workspace = true
arc-swap.workspace = true
-bytes.workspace = true
bytesize.workspace = true
gethostname.workspace = true
hex.workspace = true
@@ -46,9 +44,7 @@ reqwest = { workspace = true, optional = true }
pnet_datalink.workspace = true
futures.workspace = true
-futures-util.workspace = true
tokio.workspace = true
-tokio-stream.workspace = true
opentelemetry.workspace = true
[features]