aboutsummaryrefslogtreecommitdiff
path: root/src/model/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2024-02-07 14:59:40 +0000
committerAlex <alex@adnab.me>2024-02-07 14:59:40 +0000
commit5d941e0100489fff552b59f0679a2a010403a21c (patch)
tree5c5cef9af72d48dd7347922341e43f0013380c60 /src/model/Cargo.toml
parentfeeb076b7f5db7fe6fdbe3d2903fae054cde6219 (diff)
parente011941964b1c1e0b90f85014d166d64a83ae8e2 (diff)
downloadgarage-5d941e0100489fff552b59f0679a2a010403a21c.tar.gz
garage-5d941e0100489fff552b59f0679a2a010403a21c.zip
Merge pull request 'Dependency upgrades: http, hyper, aws-sdk, smaller deps' (#703) from dep-upgrade-202402 into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/703
Diffstat (limited to 'src/model/Cargo.toml')
-rw-r--r--src/model/Cargo.toml40
1 files changed, 20 insertions, 20 deletions
diff --git a/src/model/Cargo.toml b/src/model/Cargo.toml
index 8ecd5d63..d4a1a711 100644
--- a/src/model/Cargo.toml
+++ b/src/model/Cargo.toml
@@ -20,26 +20,26 @@ garage_table.workspace = true
garage_block.workspace = true
garage_util.workspace = true
-async-trait = "0.1.7"
-arc-swap = "1.0"
-blake2 = "0.10"
-chrono = "0.4"
-err-derive = "0.3"
-hex = "0.4"
-base64 = "0.21"
-tracing = "0.1"
-rand = "0.8"
-zstd = { version = "0.12", default-features = false }
-
-serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
-serde_bytes = "0.11"
-
-futures = "0.3"
-futures-util = "0.3"
-tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
-opentelemetry = "0.17"
-
-netapp = "0.10"
+async-trait.workspace = true
+arc-swap.workspace = true
+blake2.workspace = true
+chrono.workspace = true
+err-derive.workspace = true
+hex.workspace = true
+base64.workspace = true
+tracing.workspace = true
+rand.workspace = true
+zstd.workspace = true
+
+serde.workspace = true
+serde_bytes.workspace = true
+
+futures.workspace = true
+futures-util.workspace = true
+tokio.workspace = true
+opentelemetry.workspace = true
+
+netapp.workspace = true
[features]
default = [ "sled", "lmdb", "sqlite" ]