aboutsummaryrefslogtreecommitdiff
path: root/src/model/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-09-06 17:09:43 +0200
committerAlex Auvolat <alex@adnab.me>2022-09-06 17:09:43 +0200
commitb886c75450e3ee6a7c2b0a8265d7ada20a4d9d75 (patch)
treeac5470d56a73e14698bb1b3d24ee173e720d55c1 /src/model/Cargo.toml
parent48ffaaadfc790142ed9556f5227913fa8c32d2ed (diff)
downloadgarage-b886c75450e3ee6a7c2b0a8265d7ada20a4d9d75.tar.gz
garage-b886c75450e3ee6a7c2b0a8265d7ada20a4d9d75.zip
Make all DB engines optional build features
Diffstat (limited to 'src/model/Cargo.toml')
-rw-r--r--src/model/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/model/Cargo.toml b/src/model/Cargo.toml
index 7b831538..cb0017b2 100644
--- a/src/model/Cargo.toml
+++ b/src/model/Cargo.toml
@@ -46,3 +46,6 @@ netapp = "0.4"
[features]
k2v = [ "garage_util/k2v" ]
+lmdb = [ "garage_db/lmdb" ]
+sled = [ "garage_db/sled" ]
+sqlite = [ "garage_db/sqlite" ]