aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <lx@deuxfleurs.fr>2025-01-31 18:47:30 +0100
committerAlex Auvolat <lx@deuxfleurs.fr>2025-01-31 18:47:30 +0100
commit4563313f87af4b7be26152164a5ce09a451da0d9 (patch)
tree1203788ebe76e71678691f9ff04029bd287d2488 /src/k2v-client/Cargo.toml
parentafa28706e5566737376f8448bcc548f780f0f57f (diff)
downloadgarage-4563313f87af4b7be26152164a5ce09a451da0d9.tar.gz
garage-4563313f87af4b7be26152164a5ce09a451da0d9.zip
use cargo-shear to remove many unused dependencies between crates
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 694be1f8..bbd09b19 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -29,12 +29,11 @@ tokio.workspace = true
# cli deps
clap = { workspace = true, optional = true }
format_table = { workspace = true, optional = true }
-tracing = { workspace = true, optional = true }
tracing-subscriber = { workspace = true, optional = true }
[features]
-cli = ["clap", "tokio/fs", "tokio/io-std", "tracing", "tracing-subscriber", "format_table"]
+cli = ["clap", "tokio/fs", "tokio/io-std", "tracing-subscriber", "format_table"]
[lib]
path = "lib.rs"