aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-02-05 19:57:35 +0100
committerAlex Auvolat <alex@adnab.me>2024-02-05 19:57:35 +0100
commit81ccd4586ebdf707dfd37d4802e0cf475e11e004 (patch)
tree66355871fc313bf4cdde0866b335b4408597745d /src/k2v-client/Cargo.toml
parenta22bd319202f05bce4ad13072238c7ba81d518fb (diff)
downloadgarage-81ccd4586ebdf707dfd37d4802e0cf475e11e004.tar.gz
garage-81ccd4586ebdf707dfd37d4802e0cf475e11e004.zip
[dep-upgrade-202402] upgrade to http/hyper 1.x for tests
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 9f27c47d..694be1f8 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -13,11 +13,13 @@ base64.workspace = true
sha2.workspace = true
hex.workspace = true
http.workspace = true
+http-body-util.workspace = true
log.workspace = true
aws-sigv4.workspace = true
aws-sdk-config.workspace = true
percent-encoding.workspace = true
-hyper = { workspace = true, default-features = false, features = ["client", "http1", "http2"] }
+hyper = { workspace = true, default-features = false, features = ["http1", "http2"] }
+hyper-util.workspace = true
hyper-rustls.workspace = true
serde.workspace = true
serde_json.workspace = true