aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-05-18 13:04:17 +0200
committerAlex Auvolat <alex@adnab.me>2023-05-19 12:08:29 +0200
commit644e8722641c826603f7ee3c2c7b58f31ab88c23 (patch)
treef70c6515c3dc937d149f20528fddb74684727a68 /src/k2v-client/Cargo.toml
parent03efc191c1697140d24c431e88bd4964c77823e5 (diff)
downloadgarage-644e8722641c826603f7ee3c2c7b58f31ab88c23.tar.gz
garage-644e8722641c826603f7ee3c2c7b58f31ab88c23.zip
Port k2v-client to aws-sigv4 since rusoto_signature is deprecated
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 79af5242..886f6f49 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -10,13 +10,15 @@ readme = "../../README.md"
[dependencies]
base64 = "0.21"
+sha2 = "0.10"
+hex = "0.4"
http = "0.2"
log = "0.4"
-rusoto_core = { version = "0.48.0", default-features = false, features = ["rustls"] }
-rusoto_credential = "0.48.0"
-rusoto_signature = "0.48.0"
-hyper-rustls = { version = "0.23", default-features = false, features = [ "http1", "http2", "tls12" ] }
-serde = "1.0"
+aws-sigv4 = "0.55"
+percent-encoding = "2.2"
+hyper = { version = "0.14", default-features = false, features = ["client", "http1", "http2"] }
+hyper-rustls = { version = "0.24", features = ["http2"] }
+serde = { version = "1.0", features = [ "derive" ] }
serde_json = "1.0"
thiserror = "1.0"
tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }