aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-05-11 10:16:33 +0000
committerAlex <alex@adnab.me>2023-05-11 10:16:33 +0000
commitea9b15f669703eb74e340599dd1fbc216bb38df8 (patch)
tree4f34b0902cb79ec68958de6bea724acca4c80652 /src/k2v-client/Cargo.toml
parent375270afd19a8ce2aa3ff99bd0fc3ccab638c223 (diff)
parent2e6bb3f7669e74e163f9556ec4dcac0447bd240d (diff)
downloadgarage-ea9b15f669703eb74e340599dd1fbc216bb38df8.tar.gz
garage-ea9b15f669703eb74e340599dd1fbc216bb38df8.zip
Merge pull request 'cargo: tokio-1.28 and hyper-0.14.26 update' (#569) from jpds/garage:tokio-1.28 into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/569
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 27e85651..f49d3205 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -19,7 +19,7 @@ hyper-rustls = { version = "0.23", default-features = false, features = [ "http1
serde = "1.0"
serde_json = "1.0"
thiserror = "1.0"
-tokio = "1.24"
+tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
# cli deps
clap = { version = "4.1", optional = true, features = ["derive", "env"] }