aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2022-05-24 12:48:05 +0200
committerAlex <alex@adnab.me>2022-05-24 12:48:05 +0200
commitb2a2d3859fefd53dab0b87274d5aed1f6bb608a3 (patch)
tree27ea51873d356ccf79ce1f465fd1993861cb9886 /src/k2v-client/Cargo.toml
parent382e74c798263d042b1c6ca3788c866a8c69c4f4 (diff)
downloadgarage-b2a2d3859fefd53dab0b87274d5aed1f6bb608a3.tar.gz
garage-b2a2d3859fefd53dab0b87274d5aed1f6bb608a3.zip
K2V client improvements (#307)v0.7.2
- [x] Better distinguish error types - [x] Parse error messages received from server - [x] Remove `src/` folder layer, we don't have that for other crates Co-authored-by: Alex Auvolat <alex@adnab.me> Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/307 Co-authored-by: Alex <alex@adnab.me> Co-committed-by: Alex <alex@adnab.me>
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 84c6b8b2..224414ab 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -6,6 +6,7 @@ edition = "2018"
[dependencies]
base64 = "0.13.0"
http = "0.2.6"
+log = "0.4"
rusoto_core = "0.48.0"
rusoto_credential = "0.48.0"
rusoto_signature = "0.48.0"
@@ -22,6 +23,10 @@ garage_util = { path = "../util", optional = true }
[features]
cli = ["clap", "tokio/fs", "tokio/io-std", "garage_util"]
+[lib]
+path = "lib.rs"
+
[[bin]]
name = "k2v-cli"
+path = "bin/k2v-cli.rs"
required-features = ["cli"]