aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-05-18 09:33:03 +0000
committerAlex <alex@adnab.me>2023-05-18 09:33:03 +0000
commit03efc191c1697140d24c431e88bd4964c77823e5 (patch)
tree103270ccca9d9a26c220fce528b9a3c397fb2703 /src/k2v-client/Cargo.toml
parentc26a4308b4454e2f36e2824280b9f587a6918fa9 (diff)
parent4420db731020bf7123f2bb80b076da581836f900 (diff)
downloadgarage-03efc191c1697140d24c431e88bd4964c77823e5.tar.gz
garage-03efc191c1697140d24c431e88bd4964c77823e5.zip
Merge pull request 'K2V: double urlencoding' (#574) from fix-k2v-urlencoding into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/574
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 4212a00a..79af5242 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "k2v-client"
-version = "0.0.2"
+version = "0.0.3"
authors = ["Trinity Pointard <trinity.pointard@gmail.com>", "Alex Auvolat <alex@adnab.me>"]
edition = "2018"
license = "AGPL-3.0"
@@ -24,10 +24,12 @@ tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi
# cli deps
clap = { version = "4.1", optional = true, features = ["derive", "env"] }
format_table = { workspace = true, optional = true }
+tracing = { version = "0.1", optional = true }
+tracing-subscriber = { version = "0.3", optional = true, features = ["env-filter"] }
[features]
-cli = ["clap", "tokio/fs", "tokio/io-std", "format_table"]
+cli = ["clap", "tokio/fs", "tokio/io-std", "tracing", "tracing-subscriber", "format_table"]
[lib]
path = "lib.rs"