aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-02-05 13:02:02 +0100
committerAlex Auvolat <alex@adnab.me>2024-02-05 13:02:02 +0100
commitfe1af5d98b8e6c87f39f1d94586e61bff100e7d2 (patch)
tree188d7487cc699cc521ab46c5e06d86216edf6a3f /src/k2v-client/Cargo.toml
parentf65da26ae2627383c47b80f78f6bce54eb74d525 (diff)
downloadgarage-fe1af5d98b8e6c87f39f1d94586e61bff100e7d2.tar.gz
garage-fe1af5d98b8e6c87f39f1d94586e61bff100e7d2.zip
[dep-upgrade-202402] refactor dependencies: move all as workspace deps
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml32
1 files changed, 16 insertions, 16 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 2ccb9fe5..7c0462a5 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -9,25 +9,25 @@ repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
readme = "../../README.md"
[dependencies]
-base64 = "0.21"
-sha2 = "0.10"
-hex = "0.4"
-http = "0.2"
-log = "0.4"
-aws-sigv4 = "0.55"
-percent-encoding = "2.2"
-hyper = { version = "0.14", default-features = false, features = ["client", "http1", "http2"] }
-hyper-rustls = { version = "0.24", features = ["http2"] }
-serde = { version = "1.0", features = [ "derive" ] }
-serde_json = "1.0"
-thiserror = "1.0"
-tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
+base64.workspace = true
+sha2.workspace = true
+hex.workspace = true
+http.workspace = true
+log.workspace = true
+aws-sigv4.workspace = true
+percent-encoding.workspace = true
+hyper = { workspace = true, default-features = false, features = ["client", "http1", "http2"] }
+hyper-rustls.workspace = true
+serde.workspace = true
+serde_json.workspace = true
+thiserror.workspace = true
+tokio.workspace = true
# cli deps
-clap = { version = "4.1", optional = true, features = ["derive", "env"] }
+clap = { workspace = true, optional = true }
format_table = { workspace = true, optional = true }
-tracing = { version = "0.1", optional = true }
-tracing-subscriber = { version = "0.3", optional = true, features = ["env-filter"] }
+tracing = { workspace = true, optional = true }
+tracing-subscriber = { workspace = true, optional = true }
[features]