aboutsummaryrefslogtreecommitdiff
path: root/src/k2v-client/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-07-08 10:43:23 +0200
committerAlex Auvolat <alex@adnab.me>2022-07-08 10:43:23 +0200
commit18d014dcc5840e5eae8581a5bfa846aad93beeea (patch)
treeaccd1a78f6ef6094d2c4302e147b78458786eff8 /src/k2v-client/Cargo.toml
parentd1cf1a0fa6952e84874f36f1dc66e4a978959d8f (diff)
parentaab34bfe5415e9584432bf32e29a151dc5af9ebd (diff)
downloadgarage-18d014dcc5840e5eae8581a5bfa846aad93beeea.tar.gz
garage-18d014dcc5840e5eae8581a5bfa846aad93beeea.zip
Merge branch 'main' into background-task-manager
Diffstat (limited to 'src/k2v-client/Cargo.toml')
-rw-r--r--src/k2v-client/Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/k2v-client/Cargo.toml b/src/k2v-client/Cargo.toml
index 224414ab..2f8a2679 100644
--- a/src/k2v-client/Cargo.toml
+++ b/src/k2v-client/Cargo.toml
@@ -1,7 +1,12 @@
[package]
name = "k2v-client"
-version = "0.1.0"
+version = "0.0.1"
+authors = ["Trinity Pointard <trinity.pointard@gmail.com>", "Alex Auvolat <alex@adnab.me>"]
edition = "2018"
+license = "AGPL-3.0"
+description = "Client library for the Garage K2V protocol"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+readme = "../../README.md"
[dependencies]
base64 = "0.13.0"
@@ -17,7 +22,7 @@ tokio = "1.17.0"
# cli deps
clap = { version = "3.1.18", optional = true, features = ["derive", "env"] }
-garage_util = { path = "../util", optional = true }
+garage_util = { version = "0.7.0", path = "../util", optional = true }
[features]