aboutsummaryrefslogtreecommitdiff
path: root/src/garage/Cargo.toml
diff options
context:
space:
mode:
authortrinity-1686a <trinity@deuxfleurs.fr>2022-03-11 17:35:08 +0100
committerGitea <gitea@fake.local>2022-03-23 10:22:36 +0100
commit1eb7fdb08fed59a9e78adc24df2d96fda746c560 (patch)
tree4dd507a8676011c0793938cb37408870e93193a7 /src/garage/Cargo.toml
parente934934f149da1f4288359dcc3b6d9b9b284525e (diff)
downloadgarage-1eb7fdb08fed59a9e78adc24df2d96fda746c560.tar.gz
garage-1eb7fdb08fed59a9e78adc24df2d96fda746c560.zip
add test framework for arbitraty S3 requests
and implement some basic test with it
Diffstat (limited to 'src/garage/Cargo.toml')
-rw-r--r--src/garage/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/garage/Cargo.toml b/src/garage/Cargo.toml
index 88eff20b..86f52495 100644
--- a/src/garage/Cargo.toml
+++ b/src/garage/Cargo.toml
@@ -55,8 +55,11 @@ tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi
netapp = "0.4.1"
[dev-dependencies]
-aws-sdk-s3 = "0.6"
+aws-sdk-s3 = "0.8"
+chrono = "0.4"
http = "0.2"
+hmac = "0.10"
hyper = { version = "0.14", features = ["client", "http1", "runtime"] }
+sha2 = "0.9"
static_init = "1.0"