aboutsummaryrefslogtreecommitdiff
path: root/src/garage/Cargo.toml
diff options
context:
space:
mode:
authorJill <kokakiwi@deuxfleurs.fr>2022-02-02 15:35:52 +0100
committerJill <kokakiwi@deuxfleurs.fr>2022-02-10 17:55:49 +0100
commitdd407e7041102f52611336bef304c3266a4d6fbe (patch)
tree01582c8158cdfc19a46288e04ea53da95da5a64a /src/garage/Cargo.toml
parentaf261e17895d5d3b3bd0bdfd52b3d0db6a984a20 (diff)
downloadgarage-dd407e7041102f52611336bef304c3266a4d6fbe.tar.gz
garage-dd407e7041102f52611336bef304c3266a4d6fbe.zip
tests: Add garage integration tests (base)
Diffstat (limited to 'src/garage/Cargo.toml')
-rw-r--r--src/garage/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/garage/Cargo.toml b/src/garage/Cargo.toml
index cd6564ce..82ae1896 100644
--- a/src/garage/Cargo.toml
+++ b/src/garage/Cargo.toml
@@ -12,6 +12,10 @@ readme = "../../README.md"
name = "garage"
path = "main.rs"
+[[test]]
+name = "integration"
+path = "tests/lib.rs"
+
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
@@ -45,3 +49,9 @@ tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi
#netapp = { version = "0.3.0", git = "https://git.deuxfleurs.fr/lx/netapp" }
netapp = "0.3.0"
+
+[dev-dependencies]
+aws-sdk-s3 = "0.6"
+http = "0.2"
+
+static_init = "1.0"