aboutsummaryrefslogtreecommitdiff
path: root/src/garage/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-03-18 21:59:17 +0100
committerAlex Auvolat <alex@adnab.me>2021-03-18 21:59:17 +0100
commit4c26a0b9c17fee84a64cd79a6b31968fd48effe6 (patch)
tree602788de9fea5550c33757180d8cb6fa7c7b85a5 /src/garage/Cargo.toml
parenta1014224d32151dbba7083eb03d8e500beb67f4c (diff)
downloadgarage-4c26a0b9c17fee84a64cd79a6b31968fd48effe6.tar.gz
garage-4c26a0b9c17fee84a64cd79a6b31968fd48effe6.zip
Update Cargo.toml files with AGPL license infov0.2.0
Diffstat (limited to 'src/garage/Cargo.toml')
-rw-r--r--src/garage/Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/garage/Cargo.toml b/src/garage/Cargo.toml
index a5420f8e..17d631c7 100644
--- a/src/garage/Cargo.toml
+++ b/src/garage/Cargo.toml
@@ -3,7 +3,7 @@ name = "garage"
version = "0.2.0"
authors = ["Alex Auvolat <alex@adnab.me>"]
edition = "2018"
-license = "GPL-3.0"
+license = "AGPL-3.0"
description = "Garage, an S3-compatible distributed object store for self-hosted deployments"
repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
@@ -14,26 +14,26 @@ path = "main.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-garage_util = { version = "0.2.0", path = "../util" }
+garage_api = { version = "0.2.0", path = "../api" }
+garage_model = { version = "0.2.0", path = "../model" }
garage_rpc = { version = "0.2.0", path = "../rpc" }
garage_table = { version = "0.2.0", path = "../table" }
-garage_model = { version = "0.2.0", path = "../model" }
-garage_api = { version = "0.2.0", path = "../api" }
+garage_util = { version = "0.2.0", path = "../util" }
garage_web = { version = "0.2.0", path = "../web" }
bytes = "1.0"
-rand = "0.8"
+git-version = "0.3.4"
hex = "0.4"
log = "0.4"
pretty_env_logger = "0.4"
-git-version = "0.3.4"
+rand = "0.8"
sled = "0.34"
-structopt = { version = "0.3", default-features = false }
-toml = "0.5"
rmp-serde = "0.15"
serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
+structopt = { version = "0.3", default-features = false }
+toml = "0.5"
futures = "0.3"
futures-util = "0.3"