aboutsummaryrefslogtreecommitdiff
path: root/src/garage/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-05-09 12:40:08 +0200
committerAlex Auvolat <alex@adnab.me>2023-05-09 12:40:08 +0200
commit351d734e6c035a6f22f9fe0d62a783a81a134f45 (patch)
treeded5a11616d5147ed254bba2974d3591fb1e041f /src/garage/Cargo.toml
parenta1fcf1b175cc11b4e797d81ea483538813732d6d (diff)
parentb925f53dc3b0bae77aa3f73e581faace2eb3b21a (diff)
downloadgarage-351d734e6c035a6f22f9fe0d62a783a81a134f45.tar.gz
garage-351d734e6c035a6f22f9fe0d62a783a81a134f45.zip
Merge branch 'main' into next
Diffstat (limited to 'src/garage/Cargo.toml')
-rw-r--r--src/garage/Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/garage/Cargo.toml b/src/garage/Cargo.toml
index 0cbdf890..2b366ff1 100644
--- a/src/garage/Cargo.toml
+++ b/src/garage/Cargo.toml
@@ -21,19 +21,19 @@ path = "tests/lib.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-garage_db = { version = "0.8.2", path = "../db" }
-garage_api = { version = "0.8.2", path = "../api" }
-garage_block = { version = "0.8.2", path = "../block" }
-garage_model = { version = "0.8.2", path = "../model" }
-garage_rpc = { version = "0.8.2", path = "../rpc" }
-garage_table = { version = "0.8.2", path = "../table" }
-garage_util = { version = "0.8.2", path = "../util" }
-garage_web = { version = "0.8.2", path = "../web" }
+garage_db.workspace = true
+garage_api.workspace = true
+garage_block.workspace = true
+garage_model.workspace = true
+garage_rpc.workspace = true
+garage_table.workspace = true
+garage_util.workspace = true
+garage_web.workspace = true
backtrace = "0.3"
bytes = "1.0"
bytesize = "1.1"
-timeago = "0.4"
+timeago = { version = "0.4", default-features = false }
parse_duration = "2.1"
hex = "0.4"
tracing = { version = "0.1" }
@@ -41,6 +41,7 @@ tracing-subscriber = { version = "0.3", features = ["env-filter"] }
rand = "0.8"
async-trait = "0.1.7"
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
+git-version = "0.3.4"
serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
serde_bytes = "0.11"