aboutsummaryrefslogtreecommitdiff
path: root/src/block/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-03-15 12:04:12 +0100
committerAlex Auvolat <alex@adnab.me>2022-03-23 10:25:15 +0100
commitc1d9854d2c5998adcad60784ec54659113c28a9f (patch)
treecb6bd08213ac4b97f91f9bb9ffb83244d5180e97 /src/block/Cargo.toml
parent8565f7dc314f194ba85e9a0c8a021b9565c22e36 (diff)
downloadgarage-c1d9854d2c5998adcad60784ec54659113c28a9f.tar.gz
garage-c1d9854d2c5998adcad60784ec54659113c28a9f.zip
Move block manager to separate module
Diffstat (limited to 'src/block/Cargo.toml')
-rw-r--r--src/block/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/block/Cargo.toml b/src/block/Cargo.toml
new file mode 100644
index 00000000..9cba69ee
--- /dev/null
+++ b/src/block/Cargo.toml
@@ -0,0 +1,38 @@
+[package]
+name = "garage_block"
+version = "0.7.0"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+license = "AGPL-3.0"
+description = "Block manager for the Garage object store"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+readme = "../../README.md"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_rpc = { version = "0.7.0", path = "../rpc" }
+garage_util = { version = "0.7.0", path = "../util" }
+garage_table = { version = "0.7.0", path = "../table" }
+
+opentelemetry = "0.17"
+
+async-trait = "0.1.7"
+bytes = "1.0"
+hex = "0.4"
+tracing = "0.1.30"
+rand = "0.8"
+zstd = { version = "0.9", default-features = false }
+
+sled = "0.34"
+
+rmp-serde = "0.15"
+serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
+serde_bytes = "0.11"
+
+futures = "0.3"
+futures-util = "0.3"
+tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }