aboutsummaryrefslogtreecommitdiff
path: root/src/block/Cargo.toml
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2022-09-13 15:26:08 +0200
committerAlex <alex@adnab.me>2022-09-13 15:26:08 +0200
commit11bdc971e2aaa1ef90358b7d9c1bd6a8e9743bbf (patch)
treeca460324ea6848c61c6c698a51456ff27485ea7b /src/block/Cargo.toml
parent309d7aef3f05657e2b969ab72442b2f2c350da03 (diff)
parentff30891999b5be5421b80b89da1037e943179d2d (diff)
downloadgarage-11bdc971e2aaa1ef90358b7d9c1bd6a8e9743bbf.tar.gz
garage-11bdc971e2aaa1ef90358b7d9c1bd6a8e9743bbf.zip
Merge pull request 'use netapp streaming body' (#343) from netapp-stream-body into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/343
Diffstat (limited to 'src/block/Cargo.toml')
-rw-r--r--src/block/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/block/Cargo.toml b/src/block/Cargo.toml
index 8cf5a01c..cd409001 100644
--- a/src/block/Cargo.toml
+++ b/src/block/Cargo.toml
@@ -27,6 +27,8 @@ bytes = "1.0"
hex = "0.4"
tracing = "0.1.30"
rand = "0.8"
+
+async-compression = { version = "0.3", features = ["tokio", "zstd"] }
zstd = { version = "0.9", default-features = false }
rmp-serde = "0.15"
@@ -36,7 +38,7 @@ serde_bytes = "0.11"
futures = "0.3"
futures-util = "0.3"
tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
-
+tokio-util = { version = "0.6", features = ["io"] }
[features]
system-libs = [ "zstd/pkg-config" ]