aboutsummaryrefslogtreecommitdiff
path: root/src/api/common/Cargo.toml
diff options
context:
space:
mode:
authortrinity-1686a <trinity@deuxfleurs.fr>2025-02-08 16:01:11 +0100
committertrinity-1686a <trinity@deuxfleurs.fr>2025-02-08 16:01:11 +0100
commitf034e834fa70f579bfd85745aea533b4328cbce4 (patch)
tree0ec66ad7ad96ea32b8582f1c0566959c17f4b823 /src/api/common/Cargo.toml
parentbf0f7924189444683077ce80b7d72303b2b20145 (diff)
parentd3226bfa91d4500063c5c287c6256729dcbb3f88 (diff)
downloadgarage-f034e834fa70f579bfd85745aea533b4328cbce4.tar.gz
garage-f034e834fa70f579bfd85745aea533b4328cbce4.zip
Merge branch 'main' into 1686a/s3-redirects
Diffstat (limited to 'src/api/common/Cargo.toml')
-rw-r--r--src/api/common/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/api/common/Cargo.toml b/src/api/common/Cargo.toml
new file mode 100644
index 00000000..5b9cf479
--- /dev/null
+++ b/src/api/common/Cargo.toml
@@ -0,0 +1,44 @@
+[package]
+name = "garage_api_common"
+version = "1.0.1"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+license = "AGPL-3.0"
+description = "Common functions for the API server crates for the Garage object store"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+readme = "../../README.md"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_model.workspace = true
+garage_table.workspace = true
+garage_util.workspace = true
+
+bytes.workspace = true
+chrono.workspace = true
+crypto-common.workspace = true
+err-derive.workspace = true
+hex.workspace = true
+hmac.workspace = true
+idna.workspace = true
+tracing.workspace = true
+nom.workspace = true
+pin-project.workspace = true
+sha2.workspace = true
+
+futures.workspace = true
+tokio.workspace = true
+http.workspace = true
+http-body-util.workspace = true
+hyper = { workspace = true, default-features = false, features = ["server", "http1"] }
+hyper-util.workspace = true
+url.workspace = true
+
+serde.workspace = true
+serde_json.workspace = true
+
+opentelemetry.workspace = true