aboutsummaryrefslogtreecommitdiff
path: root/src/api/admin/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <lx@deuxfleurs.fr>2025-02-01 19:07:17 +0100
committerAlex Auvolat <lx@deuxfleurs.fr>2025-02-01 19:07:17 +0100
commitfe937c290195e5451f9e533e02664548817e6e13 (patch)
tree318ba12ff76dc3e435a01a246188c6a964e572f2 /src/api/admin/Cargo.toml
parent3192088aac0e1795401304a8dec715cd343538cf (diff)
parentd601f311865b8159a7bf1801dd8f43021d0b443b (diff)
downloadgarage-fe937c290195e5451f9e533e02664548817e6e13.tar.gz
garage-fe937c290195e5451f9e533e02664548817e6e13.zip
Merge branch 'main' into next-v2
Diffstat (limited to 'src/api/admin/Cargo.toml')
-rw-r--r--src/api/admin/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/api/admin/Cargo.toml b/src/api/admin/Cargo.toml
new file mode 100644
index 00000000..94a321a6
--- /dev/null
+++ b/src/api/admin/Cargo.toml
@@ -0,0 +1,44 @@
+[package]
+name = "garage_api_admin"
+version = "1.0.1"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+license = "AGPL-3.0"
+description = "Admin API server crate for the Garage object store"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+readme = "../../README.md"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_model.workspace = true
+garage_table.workspace = true
+garage_util.workspace = true
+garage_rpc.workspace = true
+garage_api_common.workspace = true
+
+argon2.workspace = true
+async-trait.workspace = true
+err-derive.workspace = true
+hex.workspace = true
+paste.workspace = true
+tracing.workspace = true
+
+futures.workspace = true
+tokio.workspace = true
+http.workspace = true
+hyper = { workspace = true, default-features = false, features = ["server", "http1"] }
+url.workspace = true
+
+serde.workspace = true
+serde_json.workspace = true
+
+opentelemetry.workspace = true
+opentelemetry-prometheus = { workspace = true, optional = true }
+prometheus = { workspace = true, optional = true }
+
+[features]
+metrics = [ "opentelemetry-prometheus", "prometheus" ]