aboutsummaryrefslogtreecommitdiff
path: root/src/api/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-04-24 17:46:52 +0000
committerAlex Auvolat <alex@adnab.me>2020-04-24 17:46:52 +0000
commitf2e05986c4d8cdf4abfde92e51e36f456e276ccd (patch)
tree174b2797468d47d6eb5ec6e3f4d0d768bb986151 /src/api/Cargo.toml
parentd8f5e643bcee95969b59c309809710a38b0661e3 (diff)
downloadgarage-f2e05986c4d8cdf4abfde92e51e36f456e276ccd.tar.gz
garage-f2e05986c4d8cdf4abfde92e51e36f456e276ccd.zip
Starting to be S3 compatible
Diffstat (limited to 'src/api/Cargo.toml')
-rw-r--r--src/api/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/api/Cargo.toml b/src/api/Cargo.toml
index 3606c1df..0da02338 100644
--- a/src/api/Cargo.toml
+++ b/src/api/Cargo.toml
@@ -17,6 +17,10 @@ garage_core = { path = "../core" }
bytes = "0.4"
hex = "0.3"
log = "0.4"
+chrono = "0.4"
+sha2 = "0.8"
+hmac = "0.7"
+crypto-mac = "0.7"
futures = "0.3"
futures-util = "0.3"
@@ -24,5 +28,7 @@ tokio = { version = "0.2", default-features = false, features = ["rt-core", "rt-
http = "0.2"
hyper = "0.13"
+url = "2.1"
+httpdate = "0.3"