aboutsummaryrefslogtreecommitdiff
path: root/src/api/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <lx@deuxfleurs.fr>2025-01-31 18:18:04 +0100
committerAlex Auvolat <lx@deuxfleurs.fr>2025-01-31 18:18:29 +0100
commit9fa20d45bebab2a3f66b9721c3643dbd607d944d (patch)
tree4c5cc3dee19f7cbd9e146a90ef5cbddb052716d5 /src/api/Cargo.toml
parent9330fd79d3466051394f6d419a247d46da8f5151 (diff)
downloadgarage-9fa20d45bebab2a3f66b9721c3643dbd607d944d.tar.gz
garage-9fa20d45bebab2a3f66b9721c3643dbd607d944d.zip
wip: split garage_api into garage_api_{common,s3,k2v,admin}
Diffstat (limited to 'src/api/Cargo.toml')
-rw-r--r--src/api/Cargo.toml74
1 files changed, 0 insertions, 74 deletions
diff --git a/src/api/Cargo.toml b/src/api/Cargo.toml
deleted file mode 100644
index 85b78a5b..00000000
--- a/src/api/Cargo.toml
+++ /dev/null
@@ -1,74 +0,0 @@
-[package]
-name = "garage_api"
-version = "1.0.1"
-authors = ["Alex Auvolat <alex@adnab.me>"]
-edition = "2018"
-license = "AGPL-3.0"
-description = "S3 API server crate for the Garage object store"
-repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
-readme = "../../README.md"
-
-[lib]
-path = "lib.rs"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-garage_model.workspace = true
-garage_table.workspace = true
-garage_block.workspace = true
-garage_net.workspace = true
-garage_util.workspace = true
-garage_rpc.workspace = true
-
-aes-gcm.workspace = true
-argon2.workspace = true
-async-compression.workspace = true
-async-trait.workspace = true
-base64.workspace = true
-bytes.workspace = true
-chrono.workspace = true
-crc32fast.workspace = true
-crc32c.workspace = true
-crypto-common.workspace = true
-err-derive.workspace = true
-hex.workspace = true
-hmac.workspace = true
-idna.workspace = true
-tracing.workspace = true
-md-5.workspace = true
-nom.workspace = true
-pin-project.workspace = true
-sha1.workspace = true
-sha2.workspace = true
-
-futures.workspace = true
-futures-util.workspace = true
-tokio.workspace = true
-tokio-stream.workspace = true
-tokio-util.workspace = true
-
-form_urlencoded.workspace = true
-http.workspace = true
-httpdate.workspace = true
-http-range.workspace = true
-http-body-util.workspace = true
-hyper = { workspace = true, default-features = false, features = ["server", "http1"] }
-hyper-util.workspace = true
-multer.workspace = true
-percent-encoding.workspace = true
-roxmltree.workspace = true
-url.workspace = true
-
-serde.workspace = true
-serde_bytes.workspace = true
-serde_json.workspace = true
-quick-xml.workspace = true
-
-opentelemetry.workspace = true
-opentelemetry-prometheus = { workspace = true, optional = true }
-prometheus = { workspace = true, optional = true }
-
-[features]
-k2v = [ "garage_util/k2v", "garage_model/k2v" ]
-metrics = [ "opentelemetry-prometheus", "prometheus" ]