aboutsummaryrefslogtreecommitdiff
path: root/src/api/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-05-01 14:30:50 +0000
committerAlex Auvolat <alex@adnab.me>2020-05-01 14:30:50 +0000
commit33249717010b1173fc28ba188e5fe6d580fbf393 (patch)
treeeb9253a961584ac164fdaae60ba3b84b8e7ae4ab /src/api/Cargo.toml
parent3686f100b7e46d60758e4a1cc70586444ddb5f7a (diff)
downloadgarage-33249717010b1173fc28ba188e5fe6d580fbf393.tar.gz
garage-33249717010b1173fc28ba188e5fe6d580fbf393.zip
Slightly improved S3 compatibility
- ListBucket does not require any of the parameters (delimiter, prefix, max-keys, etc) - URLs are properly percent_decoded - PutObject and DeleteObject calls now answer correctly (empty body, version id in the x-amz-version-id: header)
Diffstat (limited to 'src/api/Cargo.toml')
-rw-r--r--src/api/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/api/Cargo.toml b/src/api/Cargo.toml
index 0da02338..11a42be9 100644
--- a/src/api/Cargo.toml
+++ b/src/api/Cargo.toml
@@ -30,5 +30,5 @@ http = "0.2"
hyper = "0.13"
url = "2.1"
httpdate = "0.3"
-
+percent-encoding = "2.1.0"