aboutsummaryrefslogtreecommitdiff
path: root/src/admin/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-02-17 23:28:23 +0100
committerAlex Auvolat <alex@adnab.me>2022-03-14 10:52:13 +0100
commit8c2fb0c066af7f68fdcfcdec96fa030af059bf63 (patch)
tree58a416058e31eda2cdb3a15c07e565a9ad674857 /src/admin/Cargo.toml
parentb6561f6e1bcb6a8de13a186405a480e356df89d8 (diff)
downloadgarage-8c2fb0c066af7f68fdcfcdec96fa030af059bf63.tar.gz
garage-8c2fb0c066af7f68fdcfcdec96fa030af059bf63.zip
Add tracing integration with opentelemetry
Diffstat (limited to 'src/admin/Cargo.toml')
-rw-r--r--src/admin/Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/admin/Cargo.toml b/src/admin/Cargo.toml
index 6f646869..b6bf2b3b 100644
--- a/src/admin/Cargo.toml
+++ b/src/admin/Cargo.toml
@@ -16,12 +16,15 @@ path = "lib.rs"
garage_model = { version = "0.6.0", path = "../model" }
garage_util = { version = "0.6.0", path = "../util" }
+hex = "0.4"
+
futures = "0.3"
futures-util = "0.3"
http = "0.2"
hyper = "0.14"
-log = "0.4"
+tracing = "0.1.30"
-opentelemetry = "0.17"
+opentelemetry = { version = "0.17", features = [ "rt-tokio" ] }
opentelemetry-prometheus = "0.10"
+opentelemetry-otlp = "0.10"
prometheus = "0.13"