aboutsummaryrefslogtreecommitdiff
path: root/src/admin/Cargo.toml
diff options
context:
space:
mode:
authormricher <maximilien.richer@gmail.com>2021-09-28 08:57:20 +0200
committerAlex Auvolat <alex@adnab.me>2022-03-14 10:51:12 +0100
commite349af13a7268d567c1bacc819af5b89c2d4231f (patch)
treeb50fc78efac150bbf3c005c33d39a874c5e37b41 /src/admin/Cargo.toml
parent9d44127245990cc55dbdff5a4bd0a1524348f110 (diff)
downloadgarage-e349af13a7268d567c1bacc819af5b89c2d4231f.tar.gz
garage-e349af13a7268d567c1bacc819af5b89c2d4231f.zip
Update dependencies and add admin module with metrics
- Global dependencies updated in Cargo.lock - New module created in src/admin to host: - the (future) admin REST API - the metric collection - add configuration block No metrics implemented yet
Diffstat (limited to 'src/admin/Cargo.toml')
-rw-r--r--src/admin/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/admin/Cargo.toml b/src/admin/Cargo.toml
new file mode 100644
index 00000000..9775b667
--- /dev/null
+++ b/src/admin/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "garage_admin"
+version = "0.6.0"
+authors = ["Maximilien Richer <code@mricher.fr>"]
+edition = "2018"
+license = "AGPL-3.0"
+description = "Administration and metrics REST HTTP server for Garage"
+repository = "https://git.deuxfleurs.fr/Deuxfleurs/garage"
+
+[lib]
+path = "lib.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+garage_model = { version = "0.6.0", path = "../model" }
+garage_util = { version = "0.6.0", path = "../util" }
+
+futures = "0.3"
+futures-util = "0.3"
+http = "0.2"
+hyper = "0.14"
+log = "0.4"
+
+opentelemetry = "0.17"
+opentelemetry-prometheus = "0.10"
+prometheus = "0.13"
+lazy_static = "1.4"